
Unit 7: Working with Email



Questions Covered

• What kinds of inbound and outbound email are possible in Agiloft?

• How do we configure the system to send outbound email and receive 
inbound email?

• Why set up inbound email?

• Can we use Outlook to forward or send email into the system and have it 
attached to the right records?

• Where are emails stored and where do users go to view emails sent or 
received by the system?

• What are the different ways that users can send email from the system?

• Why are outbound emails sent as bcc’s and how can we show cc’s to 
recipients?
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Working with Email Unit Overview

• In this unit we will first get an overview of the email features available in Agiloft.

• We will learn what happens when emails are sent and received by the system.

• We will learn how emails are stored and the different places they are displayed in 
the system.

• We will learn how to configure your email server to allow inbound and outbound 
email, how to set up inbound and outbound mail handling, and how to set up a 
personal inbound account for use with the Outlook plug-in.

• We will learn how to adjust permissions and searches so users see the correct 
communications.
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General Email Capabilities

• Agiloft can collect email sent to an accessible email address and create new 
records from it in the table of your choosing.

• If an inbound email is a reply to an outbound Agiloft email, that email can be 
linked to the record that sent the email and its content mapped to fields in the 
record. If parsing is enabled, specific fields may be mapped from within the body 
of the inbound email to fields in Agiloft.

• Agiloft can send emails to one or more people automatically, using an email 
action based on a template, or manually by a user in the system. 

• The Outlook plug-in can be used to send or forward emails to Agiloft and have 
them linked to a record holding the email address of the recipient or sender.

• If marketing tracking options are on, Agiloft can indicate whether a sent email 
was opened, bounced, read, and so on. It can track all links that were clicked in 
an outbound email and provide marketing campaign statistics.
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Unified Communications Structure

• All communications are stored in the All Communications table. 

▪ This table has sub-tables for emails, faxes, notes, tweets, and voice calls.

▪ By default, only the Emails sub-table is activated. If Agiloft is integrated with 
your phone system, you can activate voice calls and faxes, and if you are going 
to use Twitter integration, you can activate tweets.

• Because this table will likely have a very large number of records, there 
are several filtered points of access that provide separate windows into 
the table.

• Permissions to the main table and Email sub-table control the overall 
create/view access, while additional permissions for sending and filters 
on the Communications table visible within each table provide further 
control over what users can see and do with emails at each point.
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Sending Emails

• Emails can be sent in a variety of ways:

▪ Manually from within a record using the Email icon or New Email button.

▪ To multiple records from the table view by selecting them and clicking the Email
icon above the view.

▪ Automatically via a rule when predefined criteria are met.

▪ From the Communications tab in the left pane outside of any record.

▪ From Outlook (cc:’d to Agiloft using the Outlook plug-in).
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What Happens when an Email is Sent?

• In the All Communication table, several to/from related fields are automatically populated 
based on the sender and the recipient(s).

• If sent by a user, the sender’s Login and Company Name will be mapped to the From Login
and From Company fields.

• If sent by a rule, the From Login and From Company values will be mapped based on the 
From email address. 

Tip: If you have an outbound address used by rules, you can set up a user with a login of email 
rule with a company value of your company.

• All recipient email addresses are matched against contacts. If found, the Logins and 
Companies of those contacts are populated into the multi-value To Logins and To 
Companies fields.
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What Happens when an Email is Sent? (continued)

• If sent from a record in a table, the email is linked to that record by 

populating the Table Name and Record ID into two special fields found on the 

Background Details tab of the All Communications table. These fields are 

combined into a hyperlink which can be clicked to navigate to that record.

• If sent from the left pane Communications tab, the email will not be linked to 

a record, but will be visible in the user’s sent email link and will be visible in 

the contact record of the recipient.
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What Happens when an Email is Received?

• Email may be received either through an email account associated 
with a specific table or through an account defined as a Personal 
Inbound account.

• When email is received by a table’s inbound account, it will be 
processed according to the configuration settings for that account 
(more on that later).

▪ Typically, this involves creating a new record or updating an existing 
record in that table, based on whether the header or subject of the 
email contains a code identifying an existing table/record in Agiloft.

▪ The email will also be stored in the All Communications table and will 
be linked to the appropriate record.
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What Happens when an Email is Received? (continued)

• When email is received through a personal inbound account, it will 
be processed according to the settings applied to that account.

▪ Typically, this involved comparing the From address to specific fields in 
one or more tables in a pre-defined order until a match is found. Once 
found, the email is linked to the appropriate record.

▪ Personal inbound accounts are generally emailed from the Outlook 
plug-in which maps the From and To fields according to the email as it 
exists in Outlook.
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Where are Emails Displayed in a Record?

• Generally, emails relate to a specific record in a table. The most 
common place to view emails is in the Communications table 
within that record.
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Where are Emails Displayed in the Left Pane? 

• There are two access points for Emails in the left pane: 

▪ The Communications tab – this provides a filtered view of emails sent 
to or from the logged in user for any record in the system (or no 
record).

▪ The All Communications table – this presents the Communications 
table as any other table, with access to all records the user has 
permission to view based on their group permissions.

• We strongly recommend not showing the All Communications 
table on the left pane, as it eliminates the specific table filters 
that control what users see. 

• In many implementations, the Communications tab is also 
hidden, as it may not be relevant. 

• Group permissions can turn off both options (General tab for 
the Communications tab and the All Communications table 
permissions for the table visibility).

12



Left Pane Communications Tab

• The links for Email Inbox and Sent Emails are saved searches 
created on the All Communications table and added to the 
left pane. They can be changed and other searches can be 
created. 

• Users will only see them if the searches are made accessible 
to their groups.

• Communications unrelated to records can be sent and 
received directly from this tab:
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Permissions in the Communications Tab

• When a user navigates to the Communications tab, their view is filtered by 
three things:

▪ Group permissions for the All Communications table.

▪ A special group permission filter, on the General tab of the group permissions wizard, 
which further restricts what can be viewed through the Communications tab.

▪ We use this special filter because a staff user’s general group permissions may state they 
can view all communication records. This is necessary so they can view communications 
linked to records in any table where they can view both the record and the 
communications table. Without a filter here, the user could see communications related to 
records that they are not permitted to view.

▪ The default searches that are run when accessing communications, such as Email 
Inbox or Sent Emails. Because these are only searches, the user can click Show All 
and will be shown all communications permitted by the first two filters.
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Visibility of the All Communications Table

• Any group that has access to the All Communications table in the left 
pane will have access to all email communications in the system, unless 
complex, table-specific permissions are set for their group.

• For this reason, we generally only give admin users permission to access 
the All Communications table from the Tables menu on the left pane.

• By default, staff communications permissions restrict the user from 
viewing any email linked to an employee record where they are not in the 
To or From field. This prevents users from viewing emails about other 
employees to which they are not privy, e.g. HR related emails.

• By default, end user groups see only emails to or from themselves.
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Tips for Saved Searches on All Communications

• Because the Communications table is likely to hold millions of records, it is important 
to design filters that will run searches quickly. This is especially important when 
searching on a multi-value linked field such as To Company or To Login.

▪ The best way to accomplish this is by using a Related Table saved search. 

▪ Create a saved search on the source table, and then use a Related Table filter in the 
Communications table. The Email Inbox search is an example of just that.

• When you cannot use a Related Table, for instance if you want to match a field in the 
communication record against a field in its linked record, use the contains item 
operator instead of the contains string operator.

▪ This is much faster and more accurate.
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Setting Up Email—Order Matters

• There is a correct order in which to set up email integration with 
Agiloft:

▪ Configure the outbound email server.

▪ Set up inbound email accounts for each table in which records are to 
be created and/or updated by email.

▪ Set up outbound email behavior for each table that will be sending 
email notifications.

▪ Set up a personal inbound account if the Outlook plug-in will be used.

▪ Instruct employees how to install the Outlook plug-in.

▪ Check group permissions on the All Communications/Email table to 
ensure groups which need to send/view emails can do so.

▪ Customize default views on the All Communications table if desired.

17



Let’s Configure the Email SMTP Server

• Select Setup > Email and SMS > Configure Email Server.

If you are using Agiloft’s hosted service, you do not need to 
configure the outbound email server, but you will still want to 
identify the default outbound address for your system.

• By default, the SMTP Server is set to “localhost,” which will work if 
Sendmail is installed on your server (it is, for the training KB). 
Otherwise, you will need to identify an SMTP server to use.

▪ The SSL/TLS option is used if the server supports encryption, for 
maximum security. 

▪ If this does not work, the STARTTSL option often works, as it 
negotiates security after the initial exchange.

Practice
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Configure the Email SMTP Server (continued)

• Define a default outbound email address for your 
system. Use your-name-training@agiloft.com as 
your outbound address.

The outbound address does not have to be a “real” 
address but it must be formatted like an email 
address. 

If you do send emails using this address as the 
“from” address, it is ideal if it matches the email 
server’s domain so that it is less likely to be marked 
as spam.

• Test your email setup by entering your email 
address in the test box and clicking Finish.

Practice
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Why Do We Need an Inbound Email Account?

• It is generally a good idea to set up at least one inbound account 
for each main process table, and to use that account as the default 
outbound account for emails sent from that table. Why?

▪ This way, if the system sends an email and the recipient replies, their 
reply will come back into the system.

▪ It is not required to have any inbound accounts, but not having one 
will shut down all incoming email.

• You do not have to let people create records via the inbound email 
account. 

▪ This is controlled in the account setup options – you can prevent 
everyone from creating records, or limit creation to only registered 
users, or people within a certain domain.
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How Does an Inbound Account Work?

• Inbound email accounts associated with a particular table are 
popped by Agiloft every minute. 

• They are processed differently based on whether they contain an 
encrypted table/ID in the subject or header or not.

▪ When an email is sent by the system from a record in a table, e.g. from 
a contract or a support case, the table name and record ID are 
encrypted into the header and the subject line of the outbound email.

▪ When an email is received by the system, it looks for the encrypted ID 
in the subject or header to determine if it is a reply to an existing 
record or not. If it is, then the email is treated as an update by email. 

▪ If there is no encrypted ID found, it is treated as an email that will 
create a new record if record creation is enabled.
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Processing Updates by Email

• If the email is an update to an existing record:

▪ A communication record is created and linked to the record 
from which the original email was sent (e.g. the support case or 
contract) so it will appear within that record.

▪ The email body and attachments are typically mapped into an 
append only field and attached file field within the linked record.

▪ How the parts are mapped is defined in the inbound account 
setup on the Email Updates tab and/or the Email Parsing tab.
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Permission for Inbound Email Updates

For email updates the system does not check the permissions of 
the sender unless email parsing is turned on.

▪ Unless parsing is enabled, the update will be applied to the correct 
record without limitation (the content will be put into the fields 
mapped by the admin).

▪ This is meant to enable people who were cc’d on the original email to 
successfully reply to the system even if they are not loaded as a user.

▪ If email parsing is turned on for a reply, then the user must have edit 
permissions to both the record and to the fields being updated via 
parsing.
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Creating Records by Email

• When an email is received with no encrypted ID:

▪ If creation is permitted:

▪ AND the sender’s group has permission
to create a new record OR the account 
setup grants guests that permission:

▪ A new record is created that maps 
the content of the email according 
to the options on the Record 
Mapping tab of the Inbound Email Setup. 

▪ A communication record is created and 
linked to the new record.

▪ Otherwise, the email is discarded. 

If you want unknown users to have permission to create records, be sure to select a 
user account on the Access tab that has permission to create records in this table.

24



Inbound Email Setup Overview

• To access the Inbound Email wizard, navigate to Setup > Email and 
SMS > Configure Inbound Email.

• This wizard is used to set up email accounts allowing users to 
create new records or update existing records. 

• You can set up multiple inbound email accounts, one or many for 
each table, and define individual behaviors for each. 

• The following slides describe the options in this wizard.
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Inbound Email Wizard

• The wizard defines:

▪ The table into which the email 
will be mapped.

▪ The server and email account 
credentials. 

▪ How emails are mapped to fields.

▪ How email updates to records are to be handled.

▪ Whether unknown users are permitted to submit email and create 
records.

▪ Filters for preventing spam and out-of-office email loops.

▪ The length of time emails are stored on the server.
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Inbound Email Wizard—Table and Server Tabs

• From the Table tab, select the table for which you are setting up 
inbound email.

• Server tab: Sets the access to the POP3 or IMAP server. 

▪ In addition to POP3 and IMAP protocols, Agiloft also supports the MS 
Exchange Web DAV and Outlook Web Access methods of collecting 
email. For these protocols, select IMAP in the first option.

▪ Detailed instructions are provided on the screen for the syntax to use 
for various versions of Exchange. The syntax can be a bit tricky to get 
right, as it depends on the version and detailed configuration of 
Exchange.

▪ The Custom Port value will change automatically depending on the 
other settings, but it can be overwritten if needed.
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Inbound Email Wizard—Account Tab

• Once you have successfully connected to the server, you 
can set up the account information. 

• When you navigate to this screen, the system status 
message tells you whether the connection to the server is 
successful.

• In the first box, type the full email address as shown to 
the right.

• In the second box, just provide the account without the 
hostname.

• Enter the password into the Password field.

• Click Next to go to the next screen. A status message will 
tell you whether the account can be accessed 
successfully.
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Inbound Email Wizard—Record Mapping Tab

• This screen defines the handling of the email for record creation.

• Options on this screen control how the contents of the email, such as the Subject 
Line, Sender’s Address, To Addresses, CC Addresses, Email Message, and Attached 
Files and Images, are mapped to fields in the record.

• It also defines how to handle “from” values that include both a name and an 
email address. 

It is best to Strip out all text other than the email address if you are trying to match a 
contact record’s Email field.

• It provides a list of all fields of type Choice or Multi-choice and allows their value 
to be set for records created from this inbound account.

▪ This offers the ability to have multiple inbound accounts for different issue types or 
priorities. For example, you might have an address for 
urgent-outage@yourcompany.com mapped to Priority 1 automatically.
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Inbound Email Wizard—Email Updates Tab

• This screen defines the handling of email that updates an existing record.

• Options determine where the body of the email and the attached images 
or files are stored. It is usually best to append the body of the email into 
an Append Only field.

• The option: Do not include quoted content when mapping into the field 
above attempts to truncate any part of the email that follows a hidden 
code (which is defined to be inserted in the outbound settings). 

▪ This is intended to eliminate the “quoted” part of the email that was included 
in the response, to avoid very long and repetitious emails in a long thread of 
emails.
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Inbound Email Wizard—Email Parsing

• By default, other than the main parts of the email, the body of the email is 
not parsed to find specific field content. However, it is possible to enable 
email parsing so that additional specific fields can be mapped from the main 
body of the email. 

• If parsing is turned on, text within defined delimiters that has the format 
Field Label: Content will be mapped to the fields matching the Field Label.

• This is mostly useful for receiving emails from other systems, where those 
emails can be pre-formatted with the proper syntax. 

▪ For instance, if you have an event monitoring system and want to create a support ticket 
from an event, you might output an email with the proper syntax from the event system 
that can be parsed into specified fields in Agiloft.

▪ Note that generally the REST or SOAP protocols are more reliable for transmitting data 
between systems than email, but setting up a parsed email can be simpler. 
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Inbound Email Wizard—Email Parsing Tab

• When using parsing, you must define a delimiter string the system will use to 
start and end parsing. For example, if “Agiloft Details” is defined as the 
delimiter, the following email will set the Manager, Comments, and Priority
fields in the record:

The heading delimiter must contain the Language Code defined in the wizard. While the 
delimiter is set to “Agiloft Details” the actual email header and footer delimiters must be 
formatted as:

--Agiloft Details; en;--

--Agiloft Details--

• This tab also defines how parsing errors are handled.
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Inbound Email Wizard—Access Tab

• This tab defines options such as whether or not record creation by email is 
allowed, what to do when the sender is not recognized, who to notify if an email 
is rejected, and how long emails are left on the server after they have been 
retrieved.

▪ You can prevent records from being created by email and only permit email updates by 
setting this option:

▪ This way, you can force users to submit required 
fields, while still allowing them to reply to system 
generated outbound emails to update 
their record.

• Permission checking: When a new email is received by an account used to create 
records in a table, the system looks at the sender’s email address and checks the 
Person table for a match. If it finds one, it applies the user’s group permissions.

It is generally best to leave email on the server for one or two days, allowing time 
for troubleshooting inbound email.
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Inbound Email Wizard—Filters Tab

• The Filters tab defines options for preventing email loops and spam 
caused by out of office emails.

▪ To prevent email loops, you can discard emails from specific addresses.

▪ Discontinue auto-responding by setting 
the number of messages from a single 
address in a given timeframe.

▪ If you suspect a loop, first inspect the 
records which were automatically 
updated and then update this tab.

▪ If you have multiple inbound accounts, you 
only have to maintain these settings for a 
single account, and then click the box to 
Update all inbound email filters.
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Set Up an Inbound Email Account
• The instructions below will set up inbound email with a Gmail account. You will need 

an account to use.

• Navigate to Setup > Email and SMS > Configure Inbound Email.

▪ Click New to set up a new inbound account.

• On the Table tab, select the Task table and click Next.

• On the Server tab, select IMAP. 

▪ The hostname will be imap.gmail.com

▪ Check the SSL/TSL connection box.

▪ Custom Port = 993.

• Click Next. When you arrive at the Accounts tab, note at the top of the screen that the 
Status reads: “Communication established with imap.gmail.com.” If not, check that 
you entered your email information correctly before continuing.

Practice
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Set Up an Inbound Email Account (continued)

• On the Accounts tab, enter your email address into both the Email and 
Email Account fields. 

▪ Enter your password into the Password field and in the Folders field, enter 
“INBOX.”

▪ Click Next.

If you receive an error message like the one below, check use the information 
on the following slide to enable the proper Gmail settings. If Gmail doesn’t 
recognize Agiloft as a secure application you will be unable to connect and 
finish your account setup. 

Practice
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Gmail Settings

37

• If you’re having trouble connecting, sign in to your Gmail account, select your 
image icon in the top right corner, and click My Account. 

▪ Under Sign-In & security, select Connected apps & sites. 

▪ Turn Allow less secure apps to ON. 

Note: If you have Two-Factor Authentication enabled in Gmail this option 
will not be available.

• Next, navigate to the gear icon and choose Settings. 

▪ Navigate to the Forwarding and POP/IMAP tab. 

▪ Under IMAP Access select Enable IMAP and save your changes. 

• If you’re still having trouble connecting, navigate to 
https://www.google.com/accounts/DisplayUnlockCaptcha and follow the instructions on 
the page. 

• Go back to your Training KB and try connecting again.

Practice

https://www.google.com/accounts/DisplayUnlockCaptcha


Let’s Set Up an Inbound Email Account (continued)

• When you arrive at the Record Mapping tab, note at the top of the 
screen that the Status reads: “Email Account is Valid.” If not, check that 
you entered your email information correctly before continuing.

▪ Under Store email subject in, select Task Summary.

▪ Under Strip out, select the option to strip out all text other than the email 
address.

▪ Under Store email message in, select Task Description.

▪ For the attachment options, select the option to store the file in the Attached 
Files field.

▪ Notice the list of choice fields that can be set for tasks created through this 
email address.

▪ Click Next to navigate to the Email Updates tab.

Practice
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Let’s Set Up an Inbound Email Account (continued)

• On the Email Updates tab, choose to Store Email Body in the Working Notes 
field, appending existing content.

▪ Choose to not include quoted content.

▪ Add any attached image or non-image files to the Attached Files field.

• On the Access tab, select the check box for Enable creation of records by 
email.

▪ Select the Agiloft Admin user for: On record create if the sender is not recognized. This 
way if an email is received from an unknown person, the admin user’s permission will be 
used to create the task. 

▪ Select Anonymous User under On record update if the sender is not recognized.

▪ Do not enable forwarding.

▪ Leave email on the server for 1 day.

Practice

39



Let’s Set Up an Inbound Email Account (continued)

• On the Filters tab, click Finish.

▪ If you have some email domains or content keywords you would like to 
filter, feel free to enter them prior to clicking Finish.

• Send an email to the account you set up and test your inbound 
email configuration. A task will be created within a couple of 
minutes. Note the user shown as the creator by examining the 
History tab for the Created By value.

• If you haven’t yet done so, add your email address to a user and 
then send another email to the system. This time, that user will be 
shown as the creator.

Practice
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Tips for Inbound Email Mapping

• On the Record Mapping tab, choice fields can be set to different values by 
using separate inbound email accounts, enabling better automatic 
processing.

▪ For instance, an inbound account with the address billing@company.com can set a 
choice field to Billing, while a different inbound account, newaccount@company.com 
can set the same choice field to New Account Setup.

• On the Email Updates tab, we typically map the body of the email to an 
Append-Only field in the record.

• This way it is native to the table and can be sent with other fields in an email 
notification.

▪ For instance, you can create the following email notification: 

▪ “An email was received from $updated_by and here is its content: 
$additional_notes_latest.”
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Outbound Email—Questions Covered

• Do we need to set up outbound email for each table?

• How do we control the From and Reply-to addresses?

• How do we control how outbound mail is formatted?

• How can we track whether emails are opened or bounced?
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Outbound Email Overview

• Outbound email configuration sets the default from and reply-to addresses and 
some additional settings used for each table. 

• If you do not specifically configure outbound email for a given table, the system 
will use default values.

▪ The wizard allows you to update these options to better meet your needs.

You must have a validly formatted outbound email address when sending email, 
or emails will not be sent. This is important to remember if you use a particular 
field value (e.g. Sales Rep Email) as the outbound email address – do not use this 
option unless you can be sure that the field will always have a value.

While hosting your knowledgebase on Agiloft servers, you may elect to use 
"localhost" as your mail server, however, the spam score calculated and assigned 
to your mail by receiving servers will be worsened because the domain of the 
sending email address will not match the domain in the SMTP server name.
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Configuring Outbound Email—From Options Tab

• From the Table tab select the table for which you are setting up outbound email.

• The From Options tab controls which groups have access to the email icon on the 
action bar. Groups without access may still automatically generate emails 
through rules and workflow.

▪ Controls the default From address and Reply-to address for manually generated emails 
in the staff and end user interfaces.

▪ The From address defines the account the email “appears” to originate from.

▪ The Reply-to address defines where the response will actually be when the recipient replies.

▪ Controls which groups can change the From and Reply-to address for manual emails. 
In order to change these fields, users must also belong to a group that has edit field 
access to the From/Reply-to fields in the All Communications table. This option is a way 
of turning off access to a particular table while leaving it enabled on others. 

In order to change the From address, the group must be able to edit it and view it. You 
may choose to let some groups view but not edit.
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Configuring Outbound Email—Bounced Emails

• The From Options tab includes a setting to 
handle bounced emails:

• If the system sends an email to someone 
that bounces, the bounce notification can 
be forwarded to the address selected here.

• We recommend using a person related to 
the record, such as the Assigned Person, 
rather than sending it back to the table’s 
incoming address because the bounce 
notification may strip out the encrypted ID
in the subject line, which will prevent it 
from being attached to the correct record.
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Configuring Outbound Email—To Options Tab

• To Options tab: Defines the default To field for the staff and end user 
interfaces.

▪ Controls whether HTML or plain text is used by default.

▪ Defines whether or not original text is included when replying to an email and, 
if so, how it is formatted.

▪ Controls whether the encrypted record ID is included in the subject line by 
default. This option can be overridden in a particular email template or by the 
user when sending manually. 

The ID is required for replies to update the appropriate record.

▪ Defines which fields from the record are included by default.

▪ Determines whether or not a hidden code is included in the email to allow 
replies to truncate. This is useful for preventing prior email text from being 
included in every subsequent message.
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Configuring Outbound Email—Fields Included

• The Include Fields option on the To Options tab defines 
which fields are added to the bottom of the email text. 

• The selected fields are shown with their label and 
content, in layout order, as shown below.

▪ All Fields will include all fields that the person sending 
the email has the right to view.

▪ Based on Recipient’s Access Permissions will send all 
fields that both the person sending the email and the 
person receiving it have the right to view.

▪ Selected Fields will send the fields selected in the box, 
provided the sender has view permissions.

• Instead of showing fields below the message text, field 
variables can be inserted within the email body and 
formatted exactly as you want them. The sender must 
have view permission for a field to be populated into 
the email.
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Configuring Outbound Email—Marketing Tab

• The Marketing tab allows for the tracking of email bounces, click rates, and 
unsubscribe requests.

• If email marketing is turned on, Agiloft automatically:

▪ Adds a unique one-pixel image to emails. This allows the system to determine if the email was 
opened. The system also tracks if a user clicks on a hotlink within a record.

▪ Adds an Unsubscribe link to each email for compliance with CAN-SPAM law. If clicked, this 
updates the record as mapped.

• When users send marketing emails, they must first select a particular campaign. The 
results are tracked in the Campaign table where each record corresponds to a 
campaign.

• The Email Results tab of the campaign shows the number of emails sent and the 
percent read, clicked on, unsubscribed, etc.

• This tab controls which fields are updated when a link is clicked or the recipient 
unsubscribes.

• It also defines which campaigns can be selected.
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Let’s Set Up an Outbound Email Account

• Navigate to Setup > Email and SMS> Configure Outbound Email.

• On the Table tab, choose the Tasks table.

• On the From Options tab:

▪ Select admin, Professional Services, and Support Staff as the groups that can 
send emails.

▪ Select the table’s incoming address (the new account you set up previously) as 
the default From and Reply-to address for system generated emails.

▪ Select the table’s incoming address as the From and Reply-to for user emails.

▪ Select the sender’s address as the From address for EUI user emails.

▪ Select the sender’s email address as the address to send Bounced Emails to.

▪ Allow only the admin group to view and edit the From and Reply-to addresses

Practice
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Let’s Set Up an Outbound Email Account (continued)

• On the To Options tab, select the option to Leave the ‘To’ field blank for 
both normal and EUI emails.

• For the Include Fields option, choose Selected Fields and multi-select the 
fields you want to include, while holding down the Control key.

• For Identifying the “To” and “CC” recipients of the email: 

• Check the box to Include text note at bottom…. 

• Choose the second option to Show both email address and Full Name 
field of recipients known by the system. 

• Leave the other values as their defaults.

• On the Marketing tab, do not enable marketing on this table.

• Click Finish.

Practice
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Outbound Email: Fine Points

• How does the system know which record to update when an email update is 
received?

▪ The outbound email header contains encrypted information about the table and record 
ID from which it was sent. Because MS Exchange strips out headers when sending 
internal emails, we also add this encrypted information to the subject line of emails as a 
backup.

▪ The outbound email header also contains complete details on how and why the email 
was sent, including server URL, KB, table, rule or workflow ID which initiated the email, 
etc. This information is displayed in the communication record. It can also be viewed in 
an email received in Outlook by clicking View > Options (on older releases of Outlook) or 
File > Properties and scrolling through the Internet Header Display. This is useful when 
testing or troubleshooting surprise emails of the “why did I receive this email” variety.
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Personal Email Overview

• Personal inbound accounts are inbound accounts that are not associated with a single table. 
They are used with the Outlook Plug-in.

• Email sent to the personal email account does not create or update records. Instead, a 
search is performed on the tables specified in the Table tab of the Personal Email wizard. 
The email is linked to the first matching record found. As shown above, the default is to 
search the People and Lead tables.

• A personal email account is set up to use with the Outlook Plug-in. This plug-in cc’s emails 
sent from Outlook to the system and maintains a copy of all correspondence. Only one such 
account is needed. 

• After setting the table search order for matching records, the remaining tabs are the same 
as for standard inbound email accounts.
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Outlook Integration

• Outlook integration is possible once at least one personal inbound account is set up.

• The add-on is downloaded by users from their Home > Preferences page and installed in 
Outlook.

• Once set up, users may click a button in Outlook to cc: the system on an outbound email 
they are sending, or to copy an email they have received in Outlook into the system.

• The email will be linked to a record in Agiloft based on the personal inbound email mapping 
order defined in the Table tab of the wizard. 

• The email will also be visible in the user’s sent and received email in the system.

• For more details on the Outlook plug-in and personal inbound setup, please review 
documentation at www.agiloft.com/documentation/unified-communications-setup.pdf
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Email Summary and Conclusion

• We have learned how to configure inbound and outbound email 
accounts.

• We have learned how to track opened and bounced emails.

• We have learned how to create and update records via email.

• We have learned how to integrate Agiloft with the Outlook plug-in.
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