Unit 3: Local Fields
Text Fields
Questions Covered

- What are fields and how do we define them?
- How can we change the kinds of data we are collecting?
- What are the different data types available and how do they differ?
- What options are available when creating fields?
- How do we set default values for specific fields?
- What kinds of fields can update automatically?
Local Fields Unit Overview

- This unit covers the field data types that are local to a table – they can be fully defined without reference to fields in other tables.
- The next unit covers the more complex linked fields and embedded table data types.
- We will be building fields for the Task table we created in Unit 1, as we progress through these units.
- The **Fields** tab of the Table wizard is where most of the work is done in customizing the Agiloft system.
  - It is where new fields are added, existing fields are modified or deleted, and where relationships between tables are created.
What are Fields and Data Types?

- As we learned in Unit 1, fields store the individual pieces of information which make up the record.

- Each field is based on a data type, such as Text, Date/Time, Integer, and so on. We will be going over these data types during this unit and the next.

- Most data types fall into the categories of either local or linked fields:
  - Local fields are fully defined within the current table.
  - Linked fields are drawn from source fields defined in another table or show multiple records pulled in from another table.

- There are also some less common data types that don’t fit into either category, such as Survey Presentation and Definition fields, and WMI fields.
Data Types are Important!

- It is important to choose the correct data type when creating a field. You cannot change the data type once you have created it!

  Some common errors:

  - Using **Short Text** when you need more than 255 characters or using a **Text** field when you want a field to be short and unique.

  - Using a (single) **Choice** field when you need a **Multi-Choice** field or vice versa.

  - Using an **Integer** field when you really need a **Floating Point**.

  - Using a **Short Text** field when you should really use a linked field.

  - Example: Creating a **Text** field for **Customer Name** instead of linking to the name held in a user record.
In this unit, we will be creating fields for each of the data types with a red asterisk.

We will be coming back to action buttons in a later unit.
Creating Local Fields

- Over the next few slides, we will be looking at the local field data types and will practice creating some local fields within the Tasks table.

- We will not cover every local data type as they are not all relevant to our sample project; please review these data types in the Field wizard, reading through the text at the left.

- In order to create a new field, click **Setup Tasks** in the left pane and navigate to the **Fields** tab.
  - Hover over **New** in the action bar, and select the data type indicated on each of the following slides.

- We are going to skip setting up permissions on the new fields for now.
The Tabs of the Field Wizard

- Each data type has some unique settings and display options, but most have several options in common:
  - **General** tab: Stores the name and label of the field, also stores admin notes, which can be printed out for documentation.
  - **Options** tab: Standard options include: whether or not the field is required, has conditional visibility or editing, has a default value, and must be unique.
  - **Permissions** tab: Defines who can view/edit the field. Allows permissions of an existing field to be copied to the new field.
  - **Display** tab: Defines display details such as the field’s size and appearance on the layout, and any input and popup instructions.
Field Implementation Best Practices

• Write admin notes for fields when creating them. Admin notes can be printed out to create system documentation when you are done. Additionally, if another person takes over administrative duties, or you need to edit a field months after creation, they will help explain why a field exists.

• Until you are familiar with each data type, always touch the Display tab to be sure the display settings make sense, as it will save you time when creating layouts.

• Always label fields with titles that make sense and describe what they are used for so that anyone looking at the Fields tab can easily understand a field’s purpose.

• When building a new table, we generally skip setting permissions for fields and leave the default permissions for the admin group only.
Text Data Types

There are several data types that store text values and we will be covering each of them since they are commonly used:

- Short Text
- Text
- Append Only Text
- Compound
Short Text

- A Short Text field stores up to 255 characters of text and can be set to require a unique value.
  - Each table should have one field defined as the Summary field for that table, and a Short Text field often works best.
    - The Summary field is the field displayed in the Last Opened list in the left pane.
  - If you need a longer text field, use the Text data type. This can be of unlimited length.
  - Text-based fields can be displayed in plain text or HTML format. Decide which is needed and set the format from the beginning, as it is awkward to change it once there is data in the system.
Create a Short Text Field

• Mouse over the New link on the Fields tab of the Task Table wizard and select Short Text from the drop-down.

• Give the field the name: “Task Summary.”

• Press your tab key to copy the name to the label.

• On the Options tab, set the maximum field length to 255.
  ▪ Select the option to make the field required.
  ▪ Make this field the summary field for the Tasks table.

• On the Display tab, change the width to 50 characters.
  △ Always touch the Display tab for Short Text fields as the default values are not usually desirable.

• Finally, click Finish to save your field.
Check Your Work!

- As you create the fields for the practice examples, it is a good idea to add them to the layout and preview them to be sure they look correct. To do this:
  - Go to the Layout tab of the Table wizard.
  - Drag and drop the field(s) onto the layout.
  - Click the Preview button to check your work.
- For this training, we recommend doing this after adding every one or two fields.
- If you are not sure if your field is set up correctly, you can always check the Training Sample KB.
Text

• A **Text** field can store at least 1,000,000 characters of text - the actual limit may be higher, depending on the underlying database.
  - Example: Task Description, Problem Description.

• A **Text** field is used when more than 255 characters may be needed.

• Text fields can be displayed as **plain text**, **HTML**, or **Automatic HTML or plain text**. In the latter case, the system decides how to display the text based on the content of the field, and a radio button is displayed for the user to override the default display.

• When defined as **HTML**, text can be entered directly into the field, or into a built-in HTML editor which can be opened to aid in text entry.

• The field can include copy/pasted images if the maximum size is set to a large enough number (at least 50,000) and if it is defined as either **HTML** or **Automatic HTML or plain text** and set to **HTML** for a given record.
Create a Text Field

- Create a **Text** field and name it “Task Description.”
- Leave the default value for the format of **As plain text with hyperlinks**. This means that if a user types in a URL, the system will show it as a clickable link, but otherwise plain text format is used.
- On the **Options** tab, set the maximum field length to 10,000.
- On the **Display** tab, change the width to 115 and show 5 rows.
- Finally, click **Finish** to save your field.
Append Only Text

• This data type is used when you expect to have a series of notes input by different users. Each update is stamped with the date/time and the name of the person who added the comment, and displayed as read only, in order.

• Generally people can add new notes, but not edit previous notes, though it is possible to give edit privileges to some users.
  ▪ Example: Additional Notes, Approval Notes, Working Notes.

• You can choose to display entries in chronological order with the input box at the bottom, or in reverse chronological order with the input box at the top.

• You can include just the latest note in an automatic email. For example, in an exchange where a technician and a customer communicate via the additional notes field, rules can be set up to send only the latest update in the email instead of the entire correspondence.

• Append Only Text fields are unlimited in size.
Create an Append Only Text Field

- Create an **Append Only Text** field and name it “Working Notes.”
- On the **Display** tab, select multi-line for the **Height of Field** input option. Change it to 115 characters wide and 5 rows high. On the layout, this will make the input-box 5 rows high, instead of the default 1 row, giving the user more room to type.
- Choose to **Display entries in reverse chronological order with input box at top** (scroll to the bottom of the display options to see this special option).
- Click **Finish** to save your field.
Compound

- **Compound** fields join two or more fields together to display them as a single unit.
  - Example: the **Full Name** field in the People table is the compound of **First Name** and **Last Name**.

- You may define the separators you want between the fields, if any.
  - Example: a **Compound** field made from **Company** and **City**, may display as Agiloft/Redwood City or as Agiloft - Redwood City.

- We sometimes use **Compound** fields to require uniqueness based on more than one field value.
  - Example: In the Company table, we might require that a **Compound** field holding **Company** and **City** is unique to avoid creating duplicate companies.
Text Fields Summary

• We have learned how to use the four text data types.
  ▪ The title of the record is generally a Short Text field, that will be marked as the Summary field for that table.
  ▪ If we need longer text that won’t change much over time, we use the Text field.
  ▪ If we want to track text updates with user/date/time stamps, we use Append Only Text.
  ▪ We have seen how Compound fields take existing fields within the table and join them to create new composite fields.
Choice Fields
Choice Data Types

• There are two local data types that store choice values:
  ▪ **Choice**: Allows the user to select one choice value from a list.
  ▪ **Multi-Choice**: Allows the user to select multiple choices.
Choice fields define a set of options to display to the user. You can select an existing choice list or create a new choice list when creating this field type.

- Example: Yes/No, Priority, Task Type.

- Choices can be displayed as either radio buttons or a drop-down list.

- Other fields can have their visibility and edit permissions dependent on the value in a Choice field.
  - Example: Only show the Other Role field if the Choice field called Role has a value of “Other.”

- The list of available choices can change when the user selects a value in another choice field (hierarchical choices).

- Choices can be displayed alphabetically or in the order of the list. The list items can be dragged and dropped to reorder them while editing the choice list.
Create a Choice Field - Billable

• In the Task table, create a Choice field and name it “Billable.”

• On the General tab, the Field wizard asks you to select a choice list: click the drop-down and choose the value Yes/No.

• On the Options tab, choose to display values as radio buttons.
  ▪ Under Select the default value to display, set the default value to No.

• On the Display tab, change the default of the Display the Choices option, and have the field display two radio buttons per row. Keep the default sub-option to horizontally align checkboxes with those above them.

• Click Finish to save your field.
Create a Choice Field - Status

• Create a second **Choice** field and name it “Status.”

• This time, instead of selecting a pre-existing choice list from the drop-down menu, create a new choice list.
  - Click the **Create Choice List** button and name it “Task Status”.
  - Click into the **Choice List Item(s)** input box, and type or paste the following, with only one item per row, to add these items to our choice list:
    - Assigned, In Progress, Done, Cancelled, Pending Creator Feedback

• Click **Finish** to save your choice list.

• On the **Options** tab, select the default value to be **Assigned**.

• Click **Finish** to save your field.
Create a Choice Field – Related To

- Create another **Choice** field and name it “Related to.”
- Create a new choice list and name it “Task is Related To.”
- Add the following items to the choice list:
  - **Project**, **Opportunity**, **Customer**
- Click **Finish** to save your choice list.
- Click **Edit Choice List** and drag a choice up or down to reorder the options.
- On the **Option** tab, choose the option to make the field required and set the default value to **Project**.
- Choose to **Display values as a Drop-down list**.
- Click **Finish** to save your field.
Hierarchical Choice Fields

• Hierarchical choice fields are used when the possible values of one Choice field depend upon on the value selected in another Choice field.

💡 Example: Suppose one list contains car manufacturers and a second list contains car models. If the user selects Toyota as the manufacturer, then Camry will show up in the list of models, but Accord (a Honda) will not.

• The parent values are defined first, then the child field can be defined.
Create a Hierarchical Choice Field

- Create a Choice field and name it “Task Type.”
- Create a new choice list and name it “Related Task Type.”
- Add the following items to your choice list:
  - IT Related, Documentation, Training, Follow-up Call, Reference Request, Referral Request, Other.
- Click Finish to save your choice list.
- On the Option tab, under Dependent (hierarchical) choices, select the check box to the left of Link this field’s choices to the selections in the field, and select the value Related To from the drop-down list.
  - This makes Related To the parent field of our current field, Task Type. This means that Task Type’s choice list will change the values it displays based on the value chosen for Related To.
Create a Hierarchical Choice Field (Continued)

- Click the **Dependent Choices Wizard** button.
- This will open a new window with the Hierarchical Choice wizard.
- In the first menu labeled **Select a set of values from the parent field**, select the value **Project**.
- Hold the Ctrl key and under **Select the linked values for the field**, select the values: Documentation, Follow-up Call, IT Related, Other, Training.
- Finally, beneath **Select the default value to display**, select **Choose One**, then click **Apply Selections**.
  - Now, when a user selects **Project** in the Related To field, only the options we just set will appear in the Task Type drop-down menu.
- The value **Project** will now disappear from the list of values in the first menu.
- Using the information below, repeat the same steps for the remaining values in the menu:
  - **Opportunity**: Follow-up Call, Other.
  - **Customer**: Follow-up Call, Other, Reference Request, Referral Request.
- Click **Finish** to save your field.
Multi-Choice

- **Multi-Choice** fields are similar to **Choice** fields, but allow for the selection of none or many items from the list.
  - Example: *Skills, Company Roles, User Roles*.

- They can be displayed as checkboxes, multi-value drop-downs, or multi-select lookups.

- For an example of a **multi-choice** field, navigate to the Companies Table wizard and edit the field called *Company Roles* to see how it is setup.
  - Then edit a company record to see the result.
Choice Fields Summary

- We have learned how to use both single and multi-choice fields.
- We have learned how to create new choice lists and edit existing ones.
- We have learned how to use hierarchical choice lists.
Numeric Fields
Numeric Data Type

- There are several data types that store numeric values:
  - **Integer**: Holds whole numbers only, with a maximum of 12 digits in length.
  - **Floating Point**: Holds decimal values and can be rounded to any length, i.e. 2.675.
  - **Percentage** and **Currency**: Special cases of Floating Point fields with additional display options.
- Most numeric data types have special display options for decimal rounding, padding with zeroes, setting maximums, displaying currency symbols, grouping, and more.
- Technically, **Date** and **Time** fields are also numeric, since they are stored as a number value, but they will be discussed in the next section.
Integer

- **Integer** fields are used to store integer numbers only.
  - Example: Number of Licenses Purchased, Quantity in a P.O. Line Item, User ID.

- This data type is used rarely, as it is more limited than **Floating Point**. There is generally little or no advantage to using **Integer** over **Floating Point** unless you want to display the numbers as a drop-down list.

- As in the other numerical data types, the number may be displayed with **Grouping** or without it. **Grouping** adds the thousand separators, i.e. 1,000 instead of 1000, based on the standard grouping for the user’s locale.

- **Integer** fields have special options to display a limited range of values as a drop-down list and to enforce minimum and maximum values.
Floating Point

- **Floating Point** fields are used to store numbers that may include decimal values.
  - Example: *Billable Hours* in a Time Entry table; *Rating* in a survey.
- This is the most common numerical data type.
- Any number of decimal values and any length is supported.
Create a Floating Point Field

- Create a **Floating Point** field and name it “Billable Hours.”
- On the **Options** tab, set the default value to 0.
  - Make the visibility of this field conditional on the field **Billable** containing the value **Yes**.
  - Set **Rounding** to three digits.
- On the **Display** tab, turn **grouping** on. Do not pad with zeroes.
- Click **Finish** to save your field.
Currency and Percentage

- **Currency**: Inserts a currency symbol, such as $30.65.
  
  ☀️ The currency symbol is hard coded for the field, so if multiple currencies are in use, it is best to store the currency symbols and names in another table and select the currency for each record instead of using the currency field display.

  ☁️ It is usually best to round to 0 or 2 digits and then to choose to display a fixed number of decimals (0 or 2), so you don’t get results like $1000.5.

- **Percentage**: Adds the % sign to the field display.

  ⚠️ This has no impact on the actual value of the field, i.e. it is not stored as 1/100th of its numerical value. So when a Percentage field is used in a formula, it should be divided by 100.

  ☁️ If user enters “%” in the input box, it will be omitted.
Create a Currency Field

• Create a Currency field and name it “Billable Rate.”
• On the Options tab, set rounding to 0 decimal digits and give it a default value of 150.
• Make the visibility of this field conditional on the field Billable containing the value Yes.
• On the Display tab, change the currency symbol from None to $, and choose the option to display the “$” symbol before the number.
• Select the option to Always show 0 decimal digits and be sure Grouping is on.
• Click Finish to save your field.
Numeric Fields Summary

• We have learned the distinctions between the different numeric data types.
• We have learned the special formatting options available for such fields.
• We will learn about the Date and Time numeric fields in the next section.
Date and Time Fields
Date and Time Data Types

- There are four data types that are stored as numbers and displayed as dates and/or times or numbers to the user:
  - **Date**: Displays a date in a team-based format, e.g. May 15 2004 or 5/15/2004 or 15/5/04 or 15 May 2014.
  - **Date/Time**: Displays both a date and time in a team-based format, e.g. May 12 2014 3:30pm.
  - **Time**: Displays a time with or without seconds, based on the team settings, e.g. 14:00 or 14:00:30.
  - **Elapsed Time**: Displays a numeric value based on the number of milliseconds between two values in either decimal hours or day/hour/minute/second format, e.g. 15.875 or 15 hours 52 minutes.
Date and Time Features

- Dates and times are critical for reports and statistics, as well as triggering reminders and notifications.
- They can use calendar and clock look-ups for easy selection.
- They have special default value options that allow them to be set and updated automatically based on other criteria:
  - Example: Renewal Notification Date may be defined as “Contract End Date minus 90 days.”
  - Example: Values can be updated automatically based on changes in other fields, e.g. Date Closed can be set automatically by the system when the Status field changes from any value to Closed.
- Always touch the Options tab for Date or Date/Time fields because the default value is set to the date created.
Time Zone Support

- **Date, Date/Time, and Time** fields are stored in the KB time zone, but they can be displayed in user-specific time zones. On the **Options** tab, there is an option to define which time zone to use for a particular field:
  - **Default Time** uses the value from the three options below which is set in a global variable for the whole system called **Time Zone of Date/Time Values**. For instance, an admin can set the default value to be **Browser Time** and then any **Date/Time** fields with **Default Time** as the setting will use the **Browser Time** display.
  - **KB Time** will use the KB time zone for the display.
  - **Browser Time** will use the user’s browser’s time zone.
    - Browser time zone is the best option when you want users to see the value in their own time zone without doing any setup.
  - **User Time** uses the value from the time zone field in the user table.
Effect of Time Zone on Dates and Times

• Time zones have an impact on Date Only and Time Only fields.
  ▪ For instance if I create a ticket at 11:55pm on January 1, 2014 in my own time zone, which is PST, but the KB time zone is set to EST (3 hours later), the Date field will be stored with a value of January 2, 2014. What I see depends on which value the field is defined to display.

• A Date Only field actually includes a set time, but it is hidden from users.

• A Time Only field stores the values as a date and time, using a hidden value of Jan 1, 1970 as the date part of the value, while just displaying the time.
  ▪ This means if you use a formula to add time to a time field, you can get unexpected results if it goes past midnight, e.g. a record with a time of 09:00 may be understood to be later than a record with a time of 15:00 because it has been updated to January 2 1970 09:00.
  ▪ Time fields are rarely used, generally only to indicate the time a record is created for purposes of routing.
Localization of the Display

- **Date, Time, and Date/Time** fields can be shown in different formats for different users, e.g. dd mon yyyy, mon dd yyyy, or mm/dd/yy and with or without seconds.

- These settings are defined for each team on the Format tab, so users in different countries can be put on different teams and the displays for each team may be formatted according to that country’s standard display.

- There is currently no global variable to set the format for all users at once. It is important when creating teams to set the formats as you want them to appear for all users for whom that is the primary team.
Create a Date/Time Field

- In the Task table, create a Date/Time field and name it “Date Due”.
- On the Options tab, set the default value to use the option Date of <choose one> and choose the Date Created field. Select the option plus two days. This will set the default Date Due to two days after the time a task record is created.
- Under Please select the desired behavior, choose the option Once the field has a value never overwrite it. The effect of this option is to allow the user to set a different due date without it being overwritten to the default value.
- Click Finish to save your field.
Create a Date/Time Field

• Create a Date/Time field and name it “Date Completed.”

• On the Options tab, set the default value to use the option Date the <choose one> field and choose the Status field. Choose the option for the date it was last changed from Any value to Done.

• Under Please select the desired behavior, choose the option to Update the field whenever the underlying condition changes. The effect of this option is to update the field any time the Status goes from some value to Done (for instance if it is reopened and then completed again).

• Under Make the visibility of this field conditional click Add Condition. In the Link Values pop-up, select Status from the drop-down menu. Under contains one of these values select Done. Click Finish.

• On the Display tab, choose the Input box 22 characters wide – this way, users will realize they don’t need to populate the field manually. You could also add a field popup telling them it will be populated automatically.

• Click Finish to save your field.
Elapsed Time

• **Elapsed Time** fields store the difference between two points in time. They can use complex logic, allowing for a wide range of uses.
  
  ▪ Example: **Hours to Complete**, measuring the time between when a task is created and when it is completed.
  
  ▪ Example: **Length of Contract**, measuring the number of days between a contract start date and contract end date.

• **Comments:**
  
  ▪ They can exclude time based on a field value (**Status = Pending Customer**) or the working or non-working hours of a team (exclude weekends and non-working hours).
  
  ▪ They are typically auto-updated by the system through default values or rules and are often used in formulas or reports (e.g. **Average Working Hours to Complete Task**).
  
  ▪ They can also be displayed as a user entry block for entering time amounts:
Create an Elapsed Time Field

- Create an **Elapsed Time field** and name it “Working Hours to Complete.”
- On the **Options** tab, choose the default value to use the option: **Measure the elapsed time between two sets of events or field values.** Select the value **Date Created** from the drop-down menu, and choose the sub-option: **When some field condition is met.** Select the value **Date Completed** from the second drop-down menu.
- Under **Exclude from the calculation the following time intervals**, choose to exclude **Based on Team Values**, the **Non Working hours of the Company Team.** Note that we’ll be covering team setup in a later unit and adjusting these hours to make sense.
- This will result in the field showing the length of time between **Date Created** and **Date Completed**, counting only working hours, once the **Status** changes to **Done**.
- Under **Show time units as**, select the option **Single time unit as decimal value of Hours**.
  - Choosing to show Days results in 24 working hours being considered one day. When using working hours as a measurement, it is always best to report in hours.
- **Make the visibility of this field conditional** on the **Status** field having a value of **Done**.
- Click **Finish** to save your field.
Date and Time Fields Summary

• We learned about the storage and display options for Date, Time, and Date/Time fields.

• We learned that a date field can be set to reflect some previously created (or automatically created) date field, such as Date Created, plus or minus some number of hours/days/months, etc.

• We also learned that a date field can be set based on when a choice field changes from some value to some other value.

• We learned that elapsed time fields are useful for reports and can measure elapsed time while excluding certain time segments.
Other Local Fields
Other Local Data Types—Brief Overview

• There are several other data types:
  ▪ Action Button
  ▪ Email/Email Pager
  ▪ File/Image with Versioning
  ▪ History
  ▪ Password
  ▪ Telephone/Fax
  ▪ URL

• For more details on these and other data types, please see the main administrator manual.
Action Button

• This field type is actually a button placed within the form which performs a specified action, such as running a script, updating a record or opening a URL.

• Action Buttons can do almost anything! For example, an action button can take the contents of the current record, pass them to a script and open a new browser window at the URL returned by the script. This URL might show the status of a FedEx shipment or provide directions to a company using Google maps, etc.

• We will be creating an action button in Unit 8 and going into more detail on their uses in the section on actions.
Email and Email Pager

• An Email field stores one or more email addresses. Email fields can be configured to check email addresses for validity. For example, you can require that all email addresses contain the "@" character.

• An Email Pager field stores the email address of a pager. Email sent to a pager is sent as plain text, and all HTML formatting (if any) is automatically discarded.
The **Attached File with Versioning** data type allows files of any type to be attached to a record and has unique options such as OCR, version control and check-in/check-out controls.

- Example: A **Contract Document** field in the Contracts table.

**Comments:**

- The OCR engine can turn flat image files or image-based pdfs into a text-searchable PDF.
- There are special options on the **Option** tab for the built-in OCR engine, most of which are turned off by default. There is also an OCR action type that is more powerful and used more frequently.
- The field can hold a link to an existing Google Docs file but Google Docs maintains control and Google permissions are required to open the file. Visibility of this option is controlled by a global variable.

**Image with Versioning** fields store attached files that are displayed as pictures within the record. For example, an employee record might have a small photo of that employee. Only files with appropriate image extensions can be uploaded to this field type.
Create a File with Versioning Field

- Create a **File with Versioning** field and name it “Attached Files.”
- On the **Options** tab, set **Enable versioning** to **Yes**, and **Allow the user to attach multiple files**.
- Click **Finish** to save your field.
A **Password** field stores passwords encrypted using one-way hash encryption. Passwords are shown as asterisks in the GUI. Administrators may set an option on password fields that will require the user to reset the password the first time the user logs in.

A **Telephone/Fax** field stores a phone or fax number using a predefined format.

A **URL** field stores a web site address using http://... format.
History

• The History data type is a special embedded table, automatically generated for new tables, which creates date/user stamped history records of all edits and events that occurred in a record.

⚠ History is critical to store data that is used by reports and rules and should never be deleted.

• Comments:
  ▪ Provides a full audit trail of all changes made to a record with snapshot capability that shows what a record looked like after any set of changes.
  ▪ Admins can skip tracking of some automated actions and remove history records to avoid cluttered history reports.
  ▪ Removing a field from history tracking makes it disappear from the Advanced Search drop-down field list. Do not delete fields without reason.
History Field Display

Click the Icon to Zero-in on the changes

Click to view record after change
Local Fields Summary and Conclusion

• We have learned about the various local field data types:
  ▪ Text Fields
  ▪ Choice Fields
  ▪ Numeric Fields
  ▪ Date and Time fields
  ▪ Other Fields

• We have created many of these data types.

• To further your understanding, create some new fields and play around with the different options to see how they affect the field.
Complete the Layout and Create Some Tasks

• Create a layout with the fields you have created so far.
  ▪ We recommend creating a new tab called **Task Details** and adding your fields there.

• Preview the layout and create at least one or two tasks, trying out the visibility dependencies and the layout to be sure your fields are in the right order.
  ▪ For example, **Billable** should come before **Billable Rate** and **Billable Hours**.

• Be sure to add a tab for history and follow the standard layout for putting fields on that tab – look at the Locations table for an example of our standard layout. You may want to add the **Date Completed** and **Working Hours to Complete** to that tab.

• Be sure the **Date Due** is working properly and test the elapsed time field by waiting a few minutes and then marking the **Status** of a task as **Done**.
Create a Default View for Tasks

• If you haven’t yet created a default view, the tasks you just created will look pretty ugly! So let’s create a new view now and name it “Default” and make it accessible and the default view for all teams.

• Include the main fields you think are important (ID, Task Summary, Status, Type of Task, Billable).

• We are going to be adding more fields to the table, so we will be updating this view in the next unit.