Unit 16: Dashboards and Home Pages
Questions Covered

- What is a dashboard?
- What is a staff home page?
- Is there a difference?
- What is a widget?
Dashboards and Home Pages Unit Overview

• In this unit, we will be learning how to create and edit dashboards, home pages, and widgets to place within home pages.

• We will also review previous units by creating some embedded tables, saved searches, and charts.
What is a Dashboard?

- A **dashboard** is a collection of charts and/or summary reports from any table which are run and displayed together on a single screen. You can also include blocks of custom HTML.
Dashboard Overview

- **Dashboards** are accessed via **Home > Dashboards** in the left pane. Expand the **Home** section by clicking on the box with a plus sign.

- Any number of dashboards can be created.
- To run the reports and view a dashboard, click the view icon next to the dashboard.
- Dashboards can be automatically distributed via email in the same way as **reports**.
- Once displayed, the user can access the source report and drill-down into the data by double-clicking on the chart.
Dashboard Wizard

- Click **New** on the **dashboards** action bar to access the Dashboard wizard.

- **Components**: Add a **Chart**, **Custom Summary Report** or **HTML/Javascript** component to the dashboard, or remove an existing component.

- **Layout**: Control where the charts and components are placed within the dashboard.

- **Title**: Add the title and description.

- **Schedule**: Control if and how often the dashboard is automatically generated and written to the file system (or emailed to users).

- **Options**: Control who can see the dashboard and whether or not the associated report will be generated along with the chart.
Creating a Dashboard

• Let’s create a new dashboard to be used by helpdesk staff.

• Navigate to the Dashboards screen and click **New** to open the wizard.

• Mouse over **Add** and select **Chart**.
  - On the **Table** tab of the pop-up wizard, choose the table that contains the chart you wish to include on the dashboard. In this case, we will be adding charts from the Helpdesk Case table.

⚠ Although we are adding four charts from the same table, you can select charts from various tables as your needs require.
Creating a Dashboard (continued)

- On the **Charts** tab, select **Funnel of open Cases by Status** and click **Finish**. You will return to the Dashboard wizard.

  🌟 If the chart you want doesn’t exist yet, click **New** to launch the Charts/Reports wizard and create a new chart.

- In the same fashion, add the following three charts from the Helpdesk Case table:
  - **Total time spent by Type of Problem**
  - **Funnel of open Cases by Priority**
  - **Pie chart of Cases by Submitter Department**
Creating a Dashboard (continued)

- On the **Layout** tab, arrange the charts as you see fit.
  
  ⚠️ You can add or remove rows and columns in order to fit your desired configuration. In general, though, a screen can comfortably hold a 2x2 configuration.

- Title your dashboard **Helpdesk Cases Overview** and give it a description.

- On the **Schedule** tab, select **Never**.

- On the **Options** tab, make the dashboard accessible to its Creator and Users in these groups: **Admin** and **Support Staff**.

- Check the box to **Include HTML reports**.

- Check the box to **Show in new window**.

- Click **Finish** to close the wizard.

- You have just created your first dashboard! To see how it looks, click the view icon.
What is a Home Page?

- A **home page** is a welcome or start page that holds a collection of widgets.
- **Widgets** are small tools embedded in a home page. Available widget types include charts, tables, hotlinks, embedded webpages, images and text.
  - **Google gadgets** are no longer supported.
- Multiple home pages may be created and made available to specific user teams. Staff users can be permitted to create their own home pages.
Viewing Home Pages

- To access home pages, click **Home** in the left pane. If you are logged in as admin, you will see the Admin Welcome home page by default.
- To view another home page, mouse over the drop-down menu at the top left of the main pane.
- To create or edit home pages or widgets, select one of the options from the home page drop-down menu.
Available Widgets

• Let’s create a few **widgets** before we continue with making a new home page.

• The tabs of the Widget wizard (**General**, **Options**, and **Apply**) serve the same basic functions as they do on other wizards. However, the **Options** tab is different depending on the widget type you select on the **General** tab. For that reason, we will not outline the tabs of the wizard here.

• The available widget types are:
  - **Chart**: Display charts from any table.
  - **Table**: Show a table view, with options to set the view or add a saved search filter.
  - **Hotlink**: Add a shortcut to create a record, with optionally preset field values.
  - **Embedded webpage**: Show an external webpage right from a home page.
  - **Image**: Upload an image and caption to display.
  - **Text**: Enter custom text in the WYSIWYG or source HTML editor.
  - **Google gadget**: *Google gadgets have been deprecated.*
  - **Custom Summary Report**: Display a preconfigured custom summary report.
Managing Widgets

- To view all existing widgets, select Manage Widgets... from the Home page drop-down.
- From here, you can click New to create a widget, or edit an existing widget by clicking its edit icon.
Managing Widgets (continued)

⚠️ **Widgets** are based on charts, tables, hotlinks, etc. If the desired source data has already been set up, you will be able to select an existing chart/hotlink/etc. on the **Options** tab of the Widget wizard.

💡 If necessary, you can create the required chart, hotlink, or table search condition from within the Widget wizard.

- In this unit we will create a **chart widget** and a **table widget** as a review of previous modules. We will also learn how to set up a **hotlink widget**.
About Hotlink Widgets

- A **hotlink** can open a saved search or create a new record in any table of your choosing.
- A **hotlink widget** allows you to define one or more internal hotlinks to display on the home page.
- Hotlinks may be opened in a new window or within the home page pane.
- When you create or edit a **hotlink widget**, you will have another selection window to choose from available hotlinks or create new hotlinks and add them to the widget.
- Hotlinks can be placed in any order you like by moving them up and down the list.
Creating a Hotlink Widget

• For our practice exercise we will create a set of project management hotlinks to assist managers.

• Navigate to Home > Manage Widgets > New to open the Widget wizard.

• General:
  - Enter the widget Title and Label as “Project Manager Hotlinks.”
  - From the Widget Type drop-down, select Hotlink.
  - Use vertical padding of 4 pixels.

• Options: Select the following from the Available Hotlinks pane:
  - New Task, View My Assigned Tasks
  - On the next slide, we will create two new hotlinks.
Creating a Hotlink Widget (continued)

- Click **New** in the **Available Hotlinks** pane (from the **Options** tab) to access the Hotlink wizard.

- Enter the following information in the Hotlink wizard:
  - **Title**: New Client Project.
  - **Set the parameters you want to include in the hyperlink**:
    - **What should the link do?**: select the option **Create a New Record**.
    - **Table**: select the **Project table**.
    - **Set field**: select **Project Category**. Next, click **Add**, and then select **Client-Related** from the drop-down.
    - Click **Compose Hyperlink** to populate the **URL** field below.
    - Click **Test Hyperlink**. Make sure that the link works properly (i.e., opens a new Project record with the **Project Category** preset to Client-Related). Click **Cancel** to close the form.
    - Click **Finish** to exit the Hotlink wizard.
  - We will set up one more hotlink on the following slide.
Creating a Hotlink Widget (continued)

• Back on the Options tab, click New in the Available Hotlinks pane.

• Title: New Internal Project.
  ▪ Under Set the parameters... choose the same options as we did on the previous slide, but set the Project Category to Internal (not Client-Related).
    △ Remember to compose and test the hyperlink.
    ▪ Click Finish to close the wizard.
  ▪ Add the two new hotlinks from the Available Hotlinks pane to the Selected Hotlinks.

• On the Apply tab, Make this widget available to: Admin Team, Project Manager Team, Sales Manager Team and Support Manager Team.

• Click Finish. You will return to the Widgets table.

• You have created your first widget!
Creating a Table Widget

• Now let’s create a **table widget**.

• Click **New** from the Widget table (**Home > Manage Widgets**).

• **General:**
  - Enter the widget **Title** and **Label** as “My Assigned Projects.”
  - Select **Table** from the **Widget Type** drop-down.
  - Extend the widget across 3 columns.

• Click **Next** to move to the **Options** tab.
Creating a Table Widget (continued)

- **Options**: From the Table drop-down menu, select Project.

- The **Search Condition** option asks you which saved search to use for the table widget.
  - In this training exercise, let’s search for projects assigned to the currently logged-in user. Let’s create the search now.
  - Click **Create New Search** and create a search where:
    - **Project Manager** equals the global variable **My Full Name**, and
    - **Status** does not equal the value **Completed**.
  - On the **Options** tab, save the search using the Name and Label “My Assigned Projects.”
  - On the **Apply** tab:
    - Make this search accessible and active to: admin, Professional Services, Sales Manager, and Support Manager groups.
    - Do not make the search available in the left menu for anyone.
    - **Make this search visible in My Assigned** for the same groups as above.
    - Click **Finish** to save your search.
Creating a Table Widget (continued)

- Return to the Options tab of the Widget wizard.

- You can now select the Search Condition you created, “My Assigned Projects.”

- Choose to display the table using the Detail View, and select the option to Display the user’s default action bar...

- On the Apply tab, Make this widget visible to the Admin, Professional Services, Project Manager, Sales Manager, and Support Manager teams.

- Click Finish to return to the Widgets table.
Creating a Chart Widget

- Let’s create a chart widget.
- Again, clicking Finish on the previous slide will return you to the Widgets table (Home > Manage Widgets).
- Click New and give this widget a Title and Label of “Active Customer Projects.”
- Select the Widget Type of Chart.
- Click Next to move to the Options tab.
Creating a Chart Widget (continued)

- On the **Options** tab, select the **Project** table from the first drop-down menu.
- The next option sets which chart to use for this widget. We want to display a chart of customer projects grouped by status, but we haven't created it yet.
  - Click **New** to create a new chart. This will open the Charts/Reports wizard.
    - On the **General** tab, make sure the chart/report applies to the **Projects** table.
      - **Title** the chart “Customer Projects by Status.”
      - Check the boxes for **Graphical Chart** and **HTML** for the chart’s **Output Format**.
    - On the **X Axis** tab (**Next > X-Axis**), select the **Status** field.
    - On the **Y Axis** tab, choose the option **For each segment, show: percentage of The number of Projects**...
Creating a Chart Widget (continued)

- On the **Filter** tab, you will need to create a new *saved search* filter which searches for Project Category = Client-Related. Once created, select that saved search filter.
- On the **Grouping/Summary** tab, show records using the *Detail View*.
  - Under the **Group data by** heading, add a *New* grouping for **Project Type** summarized by the number of Projects.
- Do not schedule this report (select *Never* on the **Schedule** tab).
- Click **Finish** to save the chart and return to the **Options** tab of the Widget wizard.

  - Next, select the chart you created (Customer Projects by Status) and have the widget **Auto-refresh** every 5 minutes.
  - On the **Apply** tab, **Make this widget visible to** the Admin Team, Project Manager, Professional Services, Sales Manager, and Support Manager Teams.
  - Click **Finish** to save your widget.
  - On the next slide we will briefly cover the tabs of the Home page wizard before we continue with the practice exercise.
Tabs of the Home Page Wizard

- **General**: Define the home page’s title and description. Select widgets to use on the home page from the *Available Widgets* library, or click *New* to create a new widget. You can also edit existing widgets.

![Available Widgets](image)

- **Layout**: Define the quantity, alignment, and size of columns and rows, and control the positioning of widgets on the screen.

- **Apply**: Define which teams have access to the home page and which teams will use the home page as their default.
Creating a Home Page

• Now that we have made a few widgets, let’s create a new home page.
• To access the Home page wizard, do one of the following:
  ▪ Click Manage Home Page from the Widget table, then click New.
  ▪ Click on Home in the left pane, and then:
    ▪ Select New... from the Home page drop-down menu, or
    ▪ Select Manage... from the Home page drop-down menu, then click New from the Home page table.
Create a Home Page (continued)

- On the **General** tab of the Home Page wizard, enter the Title **Project Manager Home Page**.
- From the **Available Widgets** library, select the widgets we just created:
  - C: Active Customer Projects
  - H: Project Manager Hotlinks
  - T: My Assigned Projects
- Click **Next**.
Create a Home Page (continued)

- **Layout**: Select the option for two columns of equal width (top center option) and two rows.
  - Select the **Vertical Sizing** option to **Allow rows to extend to the maximum size**...
  - Next, define **Row 1** to **extend to 50 percent of visible home page height** and **Row 2** to **extend to 75 percent**.
  - Last, arrange the widgets as follows:
    - 💡 Because **T: My Assigned Projects** is a related table, it looks best on its own row. Keep in mind how many columns a widget spans when placing it.
- **Apply**: **Make this Home Page accessible to the Admin Team, Project Manager, Sales Manager, and Support Manager teams**.
  - Make this a **default Home Page** for the Project Manager team.
- Click **Finish** to save the home page and exit the wizard.
- Select your new **Project Manager Home Page** from the Home page drop-down, and see your results!
Home Page and Widget Permissions

The permission to create new home pages and create new widgets is set in the Manage Groups wizard. On the General tab of the wizard (Setup > Access > Manage Groups) are options to Allow Modification of Home Pages? and Allow Modification of Widgets?.

- By default, only the admin group has this permission activated.
- A group may be allowed to create, edit, and apply home pages.
- Individual groups may be permitted to create/edit widgets.
- You may wish to give staff users the right to create home pages but not widgets.
Home Page and Widget Permissions

- As you saw, the Widget wizard has an **Apply** tab where admins can define which teams can access the widget.
  - Here, making a widget accessible/visible to a team means that users on the team who can also create/edit home pages will be able to choose and use this widget when making a home page.
- If a widget is not made visible to a team on the **Apply** tab, it can still be viewed by members of the team if it is included on a home page available to that team.
  - However, the widget won’t appear in the list of available widgets when modifying a home page.
Performance Considerations

- Running charts/reports is resource intensive, and if thousands of users are running and refreshing a complex chart frequently you will experience a drain on performance.
- This is one reason you may wish to restrict which teams can create widgets.
- For resource intensive charts, you may choose to not have them auto-refresh and instead allow the user to refresh the chart manually. Charts can be refreshed by clicking the refresh icon next to the chart on their home page.
Layout Considerations

- Creating an attractive home page layout requires some experimentation.
- Charts can become a little squeezed, depending on the title and chart options chosen.
- Clicking on a chart within a widget will expand it to full size or open a new window to enable access to an attached report, just as in a dashboard.
- For table widgets, be sure to give the widget enough room by adjusting the number of columns it occupies on the home page.
Conclusion

• This concludes the unit on working with Home pages.